Answered By: Hillary Richardson
Last Updated: Nov 10, 2014     Views: 16

For our Interlibrary Loan system ILLiad, you will need a Web browser that can handle forms, tables, and, preferably Cascading Style Sheets (CSS). We recommend the current versions of either Microsoft Internet Explorer or Mozilla Firefox.

Contact Us

Chat hours:

Email Us

Your Question
Your Info
Fields marked with * are required.